File Details

Download this file | Go to files list

Rome: Total Realism 6.2, next patch from 6.1 Requires RTW patch 1.2 and RTR 6.0 or 6.1+6.0 installed to work

Changes: many bug fixes.

Rometotalrealism.com

Download this file | Go to files list