File Details

Download this file | Go to files list

This mod requires Total Mayhem 1.17 to work properly. Please Uninstall the Avalanche mk.2 Mod if you have it, as you will no longer need it. Install the same way as Total Mayhem.

Download this file | Go to files list