File Details

Download this file | Go to files list

Description:

The Patchswitcher requires BfMe 1.03 as basis.

Note:
The patches are installed as mods to make sure that you can play online. So remove all mods before you use another patch than 1.03. Otherwise, the game could not run properly and you could have to reinstall BfMe.

Features:


* easy installation
* switch the patch quickly
* you can play online against other people with the same patch
* compatible with all languages

Download this file | Go to files list